Test day, February 8th

Testing results for GNOME 3.20. Test conducted on 8 February, using latest GNOME Continuous image from 5 February, run in Boxes.

Tests conducted by AllanDay and JakubSteiner.

Initial setup

Initial setup - language selection

Initial setup - typing

Initial setup - privacy

Initial setup - time zone

Initial setup - online accounts

Initial setup - about you

  • Old profile picture chooser doesn't look great - old fashioned style, small thumbnails.

Initial setup - ready to go

New session



Software is essentially broken in continuous, due to it not having a functional packagekit.

  • Oddly depopulated. (Screenshot.)

  • Installed view is also empty. (Screenshot.)

  • When I click on weather, I see a spinner in the middle of the window which doesn't spin (things seem to be running pretty slowly). After quite a long delay, the window populates. I actually thought it was broken because it took so long.
  • The launch button doesn't seem to have any effect.



  • Setup screen has odd layout, and doesn't encourage the user to setup online accounts. (Screenshot.)

  • Also seems to have failed to have picked up my Google account. When I go to the online accounts settings, it says that my credentials have expired though - maybe explains it. How did that happen though? (Also, seems that Calendar isn't detecting the state of the account properly.) I add the Google account again (shows squashed GNOME logo in the sign in page; again unnecessary padding around the web view). Settings now show the online account working. However, Contacts hasn't picked up the Google account - it just shows the local address book.
  • After selecting the local address book, I am greeted by something that looks quite broken. (Screenshot.)


Some of these issues are probably a result of having a non-functional packagekit in continuous.


  • Initially shows an empty screen (with a symbolic icon). After 4/5 seconds this disappears, an in app notification pops up saying that it's fetching documents from Google, and icons appear. Comments about this:
    • It was a bit unsettling to have the empty state, and then have it replaced seemingly by magic. Would have been better to have known about the google account from the start, and shown a spinner.
    • The initial empty state is drab.

    • The thumbnails appeared in a jerky and uneven manner. It didn't feel smooth or nice.
  • View drop down - sort label is misaligned (screenshot). (This issue is present in nautilus also.)

  • Wrong sized icons in the grid (see screenshot above).
  • Clicked on collections. The app seems to have become very slow. The in-app notification is telling me that it is still fetching documents. The view toggle seems stuck. Eventually a "Documents" is not responding dialog pops up. This doesn't look great (screenshot), and the labels aren't properly aligned in the buttons (screenshot). The dialog is missing a heading, it has action buttons and a close button in the title bar.

  • I force quit the app and relaunch. The icons in the grid are now all the same size, and it seems to have stopped trying to fetch documents from my online account.
  • Collections view is oddly blank - only shows one collection, and the icon doesn't include any thumbnails (probably because it is empty) (screenshot). When I click on it, it says "No collections found", which is odd considering that I just clicked on a collection (screenshot). Not showing empty collections would solve most of these issues.


  • Missing application icon in activities overview and top bar - FIXED

  • Empty state on first run. Grey and bland - needs an initial state.
  • Initial state doesn't say how to add books.




  • Welcome graphic is misaligned (screenshot). - FIXED

  • Action bar doesn't have a background. (Screenshot.) - NOT A BUG

  • Connection headings don't have a disclosure triangle (to indicate that there are options available).
  • Connection properties:
    • Apply button is sensitive when no changes have been made - should probably be insensitive until a change has been made.
    • Text entries are a bit narrow, making the dialog feel constrained (screenshot). Would be nice to be a bit wider.

    • There seems to be some mismatched labels. Says "Edit Connection" as if performing an action, but the option that gets you to the dialog says "Properties". Then the button says "Apply". Could be better to use "Connection Properties" as the heading and "Done" as the button label? - FIXED

(Issues without bug reports have been communicated to the developers by email.)



  • Blank state is very blank. Needs work!



  • Notes have lost their background colour.

  • Note text doesn't look right - seems like headings don't have the right font, possibly? They certainly don't have the correct padding above them.
  • Text selections don't look right - selected text turns white, rather than the standard blue background.



  • A key component is missing in Continuous and the way it's presented is poor (bug 761752)

Sound Recorder



  • Comes up empty


Five or More

Four in a Row

More Games Needing Highres Icons

  • Robots, Hitori, Sudoku, Taquin, Tetravex, Tali, Quadrapassel, Klotski, Mahjongg, Lights Off, Nibbles.

ThreePointNineteen/TestDays/2016-02-08 (last edited 2016-03-07 19:22:27 by AllanDay)