Usando Eclipse com Orca

Introdução

Neste howto eu explicarei a instalação, a configuração e algumas coisas básicas do uso do Eclipse com Orca. Mais alguns artigos virão em breve, explicando algum caso especial de uso do Eclipse, como por exemplo para o desenvolvimento de plugins e coisas assim. Neste artigo eu apenas me concentrarei no uso do Eclipse para desenvolvimento em Java.

Pré-Condições

Em geral, eu tenho de dizer que eu poderia ter Eclipse funcionando corretamente com Orca somente numa máquina Ubuntu 8.04 (Hardy). Se você conseguir que ele funcione em outro sistema, por favor, deixe aqui algumas notas sobre como fazer isso.

Orca e AT

Sugiro que se obtenha as últimas revisões de ATK, gail, at-spi e orca a partir do SVN, e que elas seja instaladas corretamente como descrito na página Baixando e Instalando Orca. No tempo em que escrevi este artigo minha versão do Orca era a 2.23.5 pre.

Java e Eclipse

Para executar o Eclipse é necessário instatalar o Java Development Kit a partir da versão 1.6. Pode ser que a versão 1.5 funcione também, mas eu não a testei. E eu penso que o JDK 1.6 dará a você suporte completo ao Eclipse.

Também instale o último Java Access Bridge para ter acesso às aplicações Java. Como instalar o JDK, e como instalar o último Java Access Bridge, é mostrado na página sobre o Java Access Bridge.

Para ter o Eclipse instalado simplesmente execute:

sudo aptitude -y install eclipse-sdk 

AVISO: não recomendado usar um pacote diretamente do site eclipse.org, porque pode haver problemas especiais nas versões mais novas, que torne necessários alguns ajustes prévios para que se possa executá-las no Ubuntu.

Configurando seu Ambiente

Para fazer o Eclipse funcionar corretamente com o Orca, configure a variável de ambiente JAVA_HOME. Pode-se fazer isso permanentemente adicionando ela ao arquivo /etc/bash.bashrc. Se você não configurar esta variável, o Eclipse usará outra JVM (Java Virtual Machine; em português, algo como "Máquina Virtual Java") na qual nenhuma "ponte de acesso" (Java Access Bridge) está instalada. Então abra o arquivo bash.bashrc com seu editor favorito (neste exemplo eu usei o nano):

sudo nano /etc/bash.bashrc 

Vá para o fim do arquivo e adicione a seguinte linhas:

export $JAVA_HOME=/usr/lib/jvm/java-6-sun/ 

Saia do editor salvando o arquivo, pressionando Ctrl+x e confirmando "yes" (sim). Se você quer salvar o arquivo e manter o nome que foi mostrado para ele, apenas tecle Enter. Você terá de re-abrir o gnome-terminal para que as mudanças tenham efeito. Eclipe olha para essa variável no tempo de inicialização, e se ela estiver configurada, ele usará a JVM especificada.

Também é preciso criar um arquivo chamado .eclipseextensions em /usr/local/lib/eclipse/. Pode-se fazer isso com os seguintes comando:

sudo touch /usr/local/lib/eclipse/.eclipseextensions 
sudo chmod 2775 /usr/local/lib/eclipse/.eclipseextensions 
sudo chown root:staff /usr/local/lib/eclipse/.eclipseextensions 

Primeira Inicialização do Eclipse

Seleção do Workspace

Eu prefiro executar o Eclipse a partir da linha de comando, para ter mais controle dos argumentos passados para a a máquina virtual, e também dos parâmetros de inicialização passados para o Eclipse. Mas antes de vocês executar ele pela primeira vez eu sugiro que você crie um workspace no qual meta dados do Eclipse serão armazenados.

mkdir ~/workspace 

Agora você pode executar Eclipse sem qualquer parâmetro, apenas digitando eclipse.

Durante a primeira inicialização o Eclipse mostrará uma caixa de diálogo entitulada "Workspace selection". Neste janela, como você pode ter adivinhado, selecione seu workspace. O foco estará no campo de texto que exibe o caminho para o workspace. Eclipe está sugerindo o caminho /home/<username>/workspace/ como padrão. Vocẽ pode usar o Tab e seguir para o botão "browse" que fica ao lado do campo de texto, para olhar outro local para o workspace. Então pressione Enter ou escolha seu workspace, e pressione Enter.

Para evitar que o Eclipse pergunte por um workspace cada vez que ele inicia há duas possibilidades:

  • Na caixa de diálogo "Select Workspace" existe um checkbox dizendo algo como "use this as the default and do not ask again" (em português: "Use este workspace como padrão e não pergunte novamente"). Se você marcar aquele checkbos, esta sua localização preferida será armazenada e esta caixa de diálogo não mais será mostrada.

  • Pode-se fornecer a localização do workspace como um parêmetro para o Eclipse digitando:

eclipse -data /path/to/your/workspace/ 

Exemplo Simples de Java para Verificar sua Instalação

Let's create the old and famous "Hello World" example for test purpose:

  • Selecione o menu File (Alt+f) ->New ->Java project.

  • Um wizard aparecerá perguntando pelas configurações para este projeto. Primeiro de tudo: entre um nome para este projeto. Eu nomeei ele HelloWorldExample. Todos os outros valores devem estar bem para este propósito. Então apenas entre o nome e pressione Enter para criar o projeto.

  • Passe para o projeto no seu Package Explorer segurando Ctrl e pressionando F7 quantas vezes forem necessárias para chegar ao Package Explorer.

Nota: segurar Ctrl e pressionar F7 sempre mostra as views abertas como uma lista e passa por elas.

  • Crie um classe selecionando menu File ->New ->Class. Outro wizard aparecerá para configurar os valores desta classe.

  • Entre um nome para ela tal como HelloWorldExample. Use Tab para chegar ao checkbox "public static void main" e marque-o para cirar uma classe contendo o método main. Use Tab para ir até o botão Finish e aperte ele.

  • A classe recém criada será mostradas no Editor. E ela já deverá ter o foco. Se não tiver, basta colocar o foco para outra view usando Ctrl+F7 e então voltando para o Editor para atualizar.

  • Vá para dentro do método main e entre:

Systtem.out.println("Hello World"); 
  • Salve o arquivo pressionando Ctrl+s.

  • Agora você pode executar ele selecionando menu Run ->Run as -> Java application. Isto pode ser feito selecionando ele a partir do menu ou diretamente, pressionando Alt+Shift+x e selecionando Java application na lista resultante.

  • A saída se enviada para o build no Console. Se ele não estiver aberto, basta selecionar menu Windows (Alt+w) ->Show view ->Console (na lista resultante). Se ele abrir, o Console deverá receber o foco sempre que uma aplicação estiver escrevendo na saída padrão ou não saída de erro padrão. (Pode-se configurar nas Preferências a execução do Console em modo debug)

Melhorando a Acessibilidade

No Geral

Desativar o Recurso "Estado da Heap"

Uma coisa que deve-se desligar quando se estiver usando Eclipe é o recurso de "mostrar o estado da heap". Pois isto (em aplicações grandes) faz com que frequentemente o Orca não leia outra coisa que não seja o estado da heap. O que não é uma boa idéia, por exemplo, quando se quer ver a saída no Console. Para evitar que o Eclipse faça isso, selecione menu Window ->Preferences, e use Tab para a árvore de categorias. Selecione "general" se já não estiver selecionado, e use Tab até o checkbox "show heap status", e marque-o. Depois use Tab para ir para o botão "Apply" e aperte ele, e então aperte o botão "OK".

Mudança da Tela "Browser"

Eclipse está usando um browser (navegador) interno para mostrar conteúdo HTML. Por exemplo, o javadoc e outras coisas como ele. Este parte da browser view está atualmete não acessível pelo Orca.

Uma maneira de contornar este problema é configurar o Firefox como browser padrão:

  • Vá para o menu Window (Alt+w) e lá para entrada "Preferences"

  • Use Tab para chegar até a árvore de categorias e selecione "general"

  • Expanda aquele item pressionando + no teclado alfa-numérico

  • Vá para baixo, para a entrada "web browser", e então use Tab para ir para o grupo de botões radio

  • Aqui, "use internal browser" estará selecionado por padrão
  • Mova o cursor para baixo, para habilitar "use external browser"
  • Use Tab e vá para a tabela de browsers disponíveis, e lá o padrão do sistema já deverá estar ativado

  • Aperte "Apply", e em seguida "OK" para salvar suas configurações

NOTA: esta maneira de contornar o problema me dar algum javadoc para saída legível, mas não tudo. Eu estou atualmente olhando uma maneira de implementar um plugin que apresente contendo que seja enviado para o browser em um formato que seja completamente legível por Orca.

Alguns Atalhos Gerais

O atalho de teclado mais importante na minha opinião é Ctrl+Shift+L. Ele mostrará todos os atalhos do Eclipse.

Aqui estão mais alguns atalhos que devem ser úteis:

  • Ctrl + F7 = mostra as views abertas no momento

  • Ctrl + E = mostra os editores abertos no momento

(você pode pular diretamente para um editor nesta view digitando as letras iniciais do nome dele)

  • Ctrl + F6 = seleciona um arquivo ou classe aberto(a) a partir de uma lista como aquela lista de views usada com Ctrl+F7

  • Ctrl + blank = recurso auto-completar (para código)

Nota: isto abrirá um lista com sugestões que você pode acessar pressionando F2

  • Ctrl + o = abre um outline com um campo de texto no topo, para se entrar uma string e diretamente se pular através de métodos, campos etc.

  • Ctrl + t (em uma classe ou interface) = mostra os membros desta classe ou interface
  • Ctrl + H = realiza uma pesquisa por um string no pacote corrente (Camel Cases [?] são permitidos, e curingas também)

  • Ctrl + Shift + t = abre tipo

Isto abrirá um campo de texto para entrar Camel Cases (?) ou nomes de tipos totalmente qualificados. Ao lado uma lista mostra os resultado encontrados, e pode ser acessada usando-se o Tab.

this will open a text field to enter Camel caes or fully qualified type name. a list beside will show the found results and can be accessed via tab.

  • Ctrl + Shift + r = abre recurso

Abrirá uma caixa de diálogo como aquela aberta para se abrir tipo, mas faz isso para todos os recursos possíveis (por exemplo, arquivos XML etc)

Plugins para Melhorar a Acessibilidade

Existe um monte de trabalho a se fazer para que Eclipse torne-se completamente acessível para o Orca. Eu estou atualmente trabalhando em alguns Plugins para Eclipse para melhorar a acessibilidade. Então, se você tem alguma sugestão de característica que seria bom termos no Eclipse deixe-me saber, e eu verei se poderei implementá-la. Basta que você me uma linha na minha página Gnome (em inglês).

Basta adicioná-la à lista ToDo do Eclipse.


Projects/Orca/Eclipse.pt_BR (last edited 2013-11-22 19:22:31 by WilliamJonMcCann)