Building Counduit from source

Dependencies

Conduit depends on the following :

  • goocanvas > 0.9.0

  • pygoocanvas
  • vobject
  • gtkmozembed (packaged as gnome-python-extras)
  • python elementtree or python 2.5
  • python sqlite3 (packaged as pysylite2) or python 2.5
  • evolution-python

Optional dependencies :

  • For opensync support you will need opensync cvs
  • For ipod photo suport you will need a cvs copy of libgpod

Installing Development Versions

Downloading

  1. Checkout from source :
    •     git clone git://git.gnome.org/conduit

Either run Conduit directly ( I ), or build and install it ( II and III )

  1. Run (no make or install needed) :
    •     cd conduit
          ./conduit/conduit
  2. Build :
    •     ./autogen.sh && make

      Configure accepts --prefix /PREFIX/DIR as a command line argument to install into a different directory.

  3. Install :
    •     sudo make install

      You may start Conduit from Applications -> Accessories

Projects/Conduit/Build (last edited 2013-11-21 21:30:17 by WilliamJonMcCann)